Easi Telecom - Emergency power maintenance – Incident details

Emergency power maintenance

Resolved
Partial outage
Started over 3 years agoLasted less than a minute

Affected

Current Issues

Operational from 4:00 AM to 4:00 AM

Updates
  • Resolved
    Resolved

    A core POP has a power systems issue that needs to be addressed urgently to keep backup power online. Services in the below areas may be affected for up to 3hours - Phoenix Mt Edgecombe Cornubia La Mercy

    Apologies for the inconvenience caused.

  • Identified
    Identified

    We are continuing to work on a fix for this incident, the issue is still intermittently occurring. We unfortunately need to wait till Monday for more spares.