Easi Telecom - WhatsApp/Facebook messenger down – Incident details

WhatsApp/Facebook messenger down

Resolved
Major outage
Started over 3 years agoLasted 30 minutes

Affected

Current Issues

Major outage from 5:58 PM to 6:28 PM

Updates
  • Resolved
    Resolved

    Services are returning to normal.

  • Identified
    Identified

    Large scale outage affecting various services in Africa.