Easi Telecom - Outage in umdloti area – Incident details

Outage in umdloti area

Resolved
Operational
Started 2 days agoLasted 43 minutes

Affected

Current Issues

Operational from 2:43 PM to 3:26 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.