Easi Telecom - Voice Outage – Incident details

Voice Outage

Monitoring
Major outage
Started 2 days ago

Affected

Current Issues

Major outage from 8:27 AM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    Services have partially restored. We are still seeing some intermittent instability though.

    We await final and full restoration from the 3rd party provider.

  • Identified
    Identified

    Upstream Voice outage affecting customers nationally. 3rd party technicians are working on the problem.