Easi Telecom - Maintenance Begins now for the next two hours – Incident details

Maintenance Begins now for the next two hours

Resolved
Under maintenance
Started over 3 years agoLasted about 3 hours

Affected

Current Issues

Under maintenance from 8:05 AM to 11:19 AM

Updates
  • Resolved
    Resolved

    Maintenance is complete. Thank you

  • Identified
    Identified

    We are conducting maintenance on a core fibre POP. Services may be affected during this time. We will notify you when complete.