Easi Telecom - Outage in Balito/Umhlali area – Incident details

Outage in Balito/Umhlali area

Resolved
Partial outage
Started over 3 years agoLasted 1 day

Affected

Current Issues

Partial outage from 6:52 PM to 11:39 AM

Updates
  • Resolved
    Resolved

    All equipment has been replaced and has been stable for the last hour. Please contact support 0872326000 if you are still offline.

    Thank you for your patience

  • Monitoring
    Monitoring

    Damage is extensive and total due to direct lightning strike. We have partially restored service until tomorrow when we can replace damaged equipment.

  • Identified
    Identified

    Power loss and ups failure suspected. We are working on the problem.