Easi Telecom - Durban CBD and Surrounds – Incident details

Durban CBD and Surrounds

Resolved
Major outage
Started over 2 years agoLasted about 6 hours

Affected

Current Issues

Major outage from 9:11 AM to 3:20 PM

Updates
  • Resolved
    Resolved

    Services have been stable.

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result.

  • Investigating
    Investigating

    We are investigating the outage.