Easi Telecom - Ballito - Outage – Incident details

Ballito - Outage

Resolved
Major outage
Started over 2 years agoLasted about 6 hours

Affected

Current Issues

Major outage from 8:42 AM to 2:51 PM

Updates
  • Resolved
    Resolved

    Power has remained stable since restored.

  • Monitoring
    Monitoring

    Power is restoring.

  • Identified
    Identified

    Owning to an ongoing 13 hour loss of power in the area, Multiple towers will now start going offline due to battery depletion. We apologize for the inconvenience. Services will restore once power returns.