Easi Telecom - Outage in Hawaan Forest Estate – Incident details

Outage in Hawaan Forest Estate

Resolved
Major outage
Started about 2 years agoLasted about 2 hours

Affected

Current Issues

Major outage from 2:55 PM to 4:48 PM

Updates
  • Resolved
    Resolved

    There was a temporary outage in the Umhlanga area. All services are back to normal operation.

  • Investigating
    Investigating

    We are currently investigating this incident.