Easi Telecom - Openserve Outage - KZN – Incident details

Openserve Outage - KZN

Resolved
Partial outage
Started 5 months agoLasted about 2 hours

Affected

Current Issues

Partial outage from 1:14 PM to 3:21 PM

Updates
  • Resolved
    Resolved

    Services are beginning to restore.

    If you are still offline, Please email support@easitelecom.co.za

  • Identified
    Identified

    Openserve is down in the province.

    We will share any updates as we receive them.